Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Yet another 4t stalling thread....

 
Post new topic   Reply to topic    Forums » Stella Discussion Previous topic :: Next topic  
Author Message
NCJ8
Member


Joined: 27 Sep 2017
Posts: 30
Location: Princeton, NJ
'12 Stella 4t

PostPosted: Sun Nov 26, 2017 12:56 am    Post subject: Yet another 4t stalling thread.... Reply with quote

After reading through (I think) all of the 4t stalling threads, and noting how common it is, I'm wondering: have we figured it out? Since this has been such a persistent problem, is there a common cause and equally common solution?

There appear to be at least four common situations, and perhaps some are related:
1) stalling with a full tank
2) stalling after extended WOT
3) stalling with a passenger
4) stalling at idle

My issue is #s 1-3, especially #1. I just shortened my fuel lines, but that didn't solve the issue. My evap was disconnected by the previous owner, so can't be that (and I plugged the tube coming from the tank...perhaps that was helpful for venting?). Next move is to try a vented 2t cap. The carb cleaning...

These seem like the typical things to try but...does one ever get rid of stalling problems completely? But for this issue, this would be the perfect bike for me, yet it's admittedly difficult to trust something that stalls or feels starved at WOT. Any advice from you 4t gurus would be most appreciated!
Back to top
View user's profile Send private message  
NCJ8
Member


Joined: 27 Sep 2017
Posts: 30
Location: Princeton, NJ
'12 Stella 4t

PostPosted: Sun Nov 26, 2017 12:59 am    Post subject: Reply with quote

I should also note that, if plugging the line coming out of the tank for the evap is a problem, I'm considering adding a one-way valve (as was done by someone else in 2013...I forget who): https://www.napaonline.com/p/NDP7301347

https://imgur.com/FJRtsDw
Back to top
View user's profile Send private message  
phunksoulbrotha
Member


Joined: 06 Aug 2015
Posts: 25
Location: Down the Rabbit Hole
Stella 4T 150

PostPosted: Sun Nov 26, 2017 3:32 pm    Post subject: Reply with quote

Many of the stalling issues are due to some sort of vapor lock in the tank. Even after drilling/venting my fuel cap and getting rid of the entire evap system, I still get stalling issues occasionally. Luckily I know why and mine is an easy fix. I have a vented cap but my new seat sits right on top of it, effectively covering the vent. So long as I'm paying attention, I can hear it start to struggle and I can raise my seat just a touch while still riding, and it goes back to running normal. The problem gets worse if the tank is full or if I am on a steep incline/decline as it puts the fuel up against the bottom of the cap and effectively plugs it from inside the tank. Still working on a permanent fix but for now, lifting the seat and letting it breathe solves it for me.
Back to top
View user's profile Send private message  
NCJ8
Member


Joined: 27 Sep 2017
Posts: 30
Location: Princeton, NJ
'12 Stella 4t

PostPosted: Mon Nov 27, 2017 3:33 pm    Post subject: Reply with quote

Thanks @phunksoulbrotha. It looks like we have the same "racing" style seat, so its good to hear that this is a short term solution. When you got rid of the evap system, did you plug the tube coming out of the tank? I did because mine was leaking gas when the tank was full, and this made stalling much worse (even after trying a vented cap yesterday). I unplugged that tube, put a shop rag there to catch gas drips, and so far, so good.

My next thought, and this might work for you too, is to put on a one way valve at the end of the evap tube coming from the tank so that air can get in but gas can't get out. Here's the link - we'll see how it goes: https://www.napaonline.com/p/NDP7301347
Back to top
View user's profile Send private message  
BigDaddy SnakeOiler
Member


Joined: 02 Feb 2015
Posts: 323
Location: EPX
Stella 4T, 300 GTS

PostPosted: Mon Nov 27, 2017 8:07 pm    Post subject: Reply with quote

Did you vent your gas cap?
_________________

Big Daddy Scooter Bum Blog


BigDaddy on FaceBook
Back to top
View user's profile Send private message  
NCJ8
Member


Joined: 27 Sep 2017
Posts: 30
Location: Princeton, NJ
'12 Stella 4t

PostPosted: Mon Nov 27, 2017 8:24 pm    Post subject: Reply with quote

@BigDaddy SnakeOiler, I am currently using a buddy's 2t cap. It didn't make a difference until I unplugged the disconnected evap tube coming from the tank, but perhaps I had overfilled to the point that the vented cap wasn't able to breathe.

Two things: would you recommend drilling out my cap (and where should I do that) or just getting a 2t cap? And what is considered "overfilling"? I tend to put as much fuel in as possible so I don't have to make frequent pit stops Wink
Back to top
View user's profile Send private message  
phunksoulbrotha
Member


Joined: 06 Aug 2015
Posts: 25
Location: Down the Rabbit Hole
Stella 4T 150

PostPosted: Tue Nov 28, 2017 2:04 am    Post subject: Reply with quote

Yeah, I threw a vacuum plug on that tube. I also get a little fuel leak from that spot but it hasn't made it past the trim ring between the tank and the paint so I haven't worried about it and wipe it dry when I refill. Let me know how the one way valve works out for you.
Back to top
View user's profile Send private message  
BigDaddy SnakeOiler
Member


Joined: 02 Feb 2015
Posts: 323
Location: EPX
Stella 4T, 300 GTS

PostPosted: Wed Nov 29, 2017 12:07 pm    Post subject: Reply with quote

I used a 1/16th drill bit and went right down the center.
_________________

Big Daddy Scooter Bum Blog


BigDaddy on FaceBook
Back to top
View user's profile Send private message  
johnk
Member


Joined: 03 Sep 2018
Posts: 58

2012 Stella 4T

PostPosted: Sat Sep 22, 2018 12:54 am    Post subject: Reply with quote

NCJ8, can you report back about the one-way valve on your EVAP? I'm considering doing the same. Thanks!
Back to top
View user's profile Send private message  
NCJ8
Member


Joined: 27 Sep 2017
Posts: 30
Location: Princeton, NJ
'12 Stella 4t

PostPosted: Sat Sep 22, 2018 1:35 pm    Post subject: @johnk Reply with quote

@johnk I just tagged you in and re-upped my posted solution. It's worked perfectly. Good luck!
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    Forums » Stella Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.