Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Buddy 125 Mechanical Question

 
Post new topic   Reply to topic    Forums » General Discussion Previous topic :: Next topic  
Author Message
bigshinybutton
Member


Joined: 09 Aug 2015
Posts: 4
Location: California
2008 Buddy 125

PostPosted: Tue Dec 10, 2019 12:03 am    Post subject: Buddy 125 Mechanical Question Reply with quote

I've got a 2008 in fantastic condition. Nearby shop closed down so I have to take over maintenance.

I remember once having a service manual but I think I lost it. Anyone have link?

Also, I have a particular issue where, after idling normally, if I apply throttle and start moving, a second later there is an uneven jerk/shake and then the scoot accelerates normally. The engine does not drag during this time, but it almost feels like a clutch/engagement thing.

Thoughts?
Back to top
View user's profile Send private message  
vintagegarage
Member


Joined: 22 Nov 2017
Posts: 73
Location: Florida
2006 Buddy 125, 2003 MyBuBu 125, 2009 Buddy 50, St. Tropez, 2009 Buddy 150, International Italia

PostPosted: Tue Dec 10, 2019 12:54 am    Post subject: Reply with quote

http://modernbuddy.com/forum/topic17349.html
Back to top
View user's profile Send private message  
Dooglas
Member


Joined: 08 Jul 2007
Posts: 4245
Location: Oregon City, OR
Buddy 125, Buddy Kick, Vespa GTS300

PostPosted: Tue Dec 10, 2019 7:12 pm    Post subject: Re: Buddy 125 Mechanical Question Reply with quote

bigshinybutton wrote:
Also, I have a particular issue where, after idling normally, if I apply throttle and start moving, a second later there is an uneven jerk/shake and then the scoot accelerates normally. The engine does not drag during this time, but it almost feels like a clutch/engagement thing.Thoughts?


Yes, it does sound like the belt could be slipping or the clutch bell needs to be deglazed. When was the last time the CVT was serviced?
Back to top
View user's profile Send private message  
scootERIK
Member


Joined: 12 Jul 2012
Posts: 402
Location: Lake Geneva, WI
Buddy 125

PostPosted: Wed Dec 11, 2019 2:56 am    Post subject: Reply with quote

It could also be bad rollers, flat spots can cause a stutter or jerk.

Another possibility is the clutch is going bad or needs service.


I would start by looking at the rollers and belt. You should at least clean out the variator(sometimes this will fix small stutters and jerks.) If the rollers are still round they still might be good, if they have flat spots then replace them. As for the belt they usually last at least ~6k the standard recommendation is to change it every 8,000 miles.
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    Forums » General Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.