Temperature Sensor Issues

Discussion of the Genuine Buddy, Hooligan, Black Jack and other topics, both scooter related and not

Moderator: Modern Buddy Staff

Post Reply
mukaiboston
Member
Posts: 295
Joined: Mon Sep 06, 2010 5:01 pm
Location: Washington, DC
Contact:

Temperature Sensor Issues

Post by mukaiboston »

I'm still trying to diagnose the rough idle and misfiring on my scooter.

I finally was able to obtain the diagnostic tool, erased the scooter's memory and then started the scooter and let it run for a bit. Then I plugged the tool into the data port to pull the codes off the dashboard.

The EMS light gives one long flash followed by a short flash which is the code for "Engine Temperature Sensor"

I'm ordering a new one, but I had pulled the temperature sensor and checked its resistance with a multimeter while putting it in ice and boiling water and it seemed okay. The ambient temperature was within the correct range, obviously ice and boiling water is a little harder to check precisely.

I'm worried the sensor is fine, but something is broken in the wiring as the wires look very flimsy. I ordered some 2.5K ohm resistors and am going to unplug the sensor and stick a resistor in there to see what happens when I start the scooter in the meantime. (2.5K is within the resistance range for ambient temperature). I don't want to just use a paper clip because then the resistance will be zero which may cause the computer to think the engine has overheated and create more issues.

It's connected to the plate you have to remove to get to the valves and things got really bad after I did a valve adjustment check. The scooter was starting to run worse prior to this point so I thought a valve adjustment was in order, but when I screwed the cover back on and started the scooter, the engine started surging really high before the light came on.

Not sure if anyone has advice but at least I was able to narrow down where the issue is thanks to the code scanner.

EMS light comes on when I turn the key on but without starting the ignition so something is obviously failing during the boot process when the system scans all the components.

I'm still shocked at how "intelligent" these scooters are but still frustrated it can't talk to me without more expensive software, data cable and a laptop.
Post Reply