rebuilt carb - now scooter doesn't have much acceleration

Discussion of the Genuine Buddy, Hooligan, Black Jack and other topics, both scooter related and not

Moderator: Modern Buddy Staff

Post Reply
User avatar
PistolPete7390
Member
Posts: 23
Joined: Wed May 03, 2017 1:14 am
Location: Manchester NH

rebuilt carb - now scooter doesn't have much acceleration

Post by PistolPete7390 »

Had a friend rebuild my carb on 2007 buddy 125 and now the scooter doesn't have any acceleration power past 30mph. Looking for help to troubleshoot this issue. Thanks in advance [/b]
User avatar
vintagegarage
Member
Posts: 86
Joined: Wed Nov 22, 2017 10:39 pm
Location: Florida

Post by vintagegarage »

Carb diaphragm isn't installed properly.. Take the diaphragm cover off, re-seat the diaphragm, put the cover back on, fixed.
User avatar
PistolPete7390
Member
Posts: 23
Joined: Wed May 03, 2017 1:14 am
Location: Manchester NH

Post by PistolPete7390 »

Thank you very much! I will have him try this tonight.
User avatar
babblefish
Member
Posts: 3107
Joined: Tue Dec 04, 2007 8:42 am
Location: San Francisco

Post by babblefish »

You might have to put a little bit of rubber safe lubricant on the sealing lip before assembly. It'll help it make a good seal.
Some people can break a crowbar in a sandbox.
User avatar
wheelbender6
Member
Posts: 735
Joined: Sun Jul 07, 2013 1:27 am
Location: Houston area

Post by wheelbender6 »

I agree with all the responses. I had the same problem a little over a year ago. Easy fix.
"It's not WHAT you ride, but THAT you ride" - unknown
Post Reply