Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Troubleshooting tips for my Roughouse to start?

 
Post new topic   Reply to topic    Forums » Black Cat, Rattler & Roughhouse Discussion Previous topic :: Next topic  
Author Message
mikethegreat
Member


Joined: 14 Aug 2017
Posts: 3
Location: DENVER
RoughHouse

PostPosted: Mon Aug 14, 2017 9:03 pm    Post subject: Troubleshooting tips for my Roughouse to start? Reply with quote

Hello, so I have been riding my 2016 Genuine Roughhouse scooter on and off this summer - I have just returned from a 3 week vacation and the scooter won't start now :/

Here's a description of what's happening:

When I put the key into on position and try to ignition, there is no "turnover" at all in the engine.

The battery I thought was the issue at first, but it's totally charged and I did so with a battery tender.

I've tried to kickstart it and put some gas but that doesn't seem to make a difference either. If there is something I should attempt to get the scooter to start, please let me know!

The gas tank has about a half tank.

Also please let me know if there's anything I'm unclear on.

Any guidance would be GREATLY appreciated.

Thanks!
Back to top
View user's profile Send private message  
luckyscroller788
Member


Joined: 30 Sep 2014
Posts: 191
Location: Southeast WI
Hoolie 170/ buddy 170

PostPosted: Mon Aug 14, 2017 11:14 pm    Post subject: Reply with quote

Check to see that the button on your right bar isn't flipped to the off position. And you are squeezing a brake right?
By turnover, do you mean the engine wont crank at all, or its cranking, but not firing?
Back to top
View user's profile Send private message  
mikethegreat
Member


Joined: 14 Aug 2017
Posts: 3
Location: DENVER
RoughHouse

PostPosted: Tue Aug 15, 2017 2:37 pm    Post subject: Reply with quote

hmm it's not the kill switch, but good thought as I hadn't checked that before.

So when I try to have ignition, it's not cranking or firing at all. Hmm, seems to be an electrical issue... I'm a bit of a noob with this stuff so I might have to call a repair place.

Thanks for the help though!
Back to top
View user's profile Send private message  
cummingsjc
Member


Joined: 30 Dec 2015
Posts: 331
Location: College Station, TX
Genuine Buddy 50cc, Genuine Mean Cat, Piaggio MP3-500 (Desert Camo), MP3-400 (Pinky)

PostPosted: Tue Aug 15, 2017 3:05 pm    Post subject: Reply with quote

If you are getting no electricity when you turn the key it might be the battery contacts are corroded. Unscrew the battery posts and check the contacts to see if there is any corrosion building up. You might try rubbing them with some fine grit sandpaper and then put a bit of dielectric grease on them before putting everything back together.

Also, when you say your battery is "totally charged" did you check this with a multimeter or are just assuming it is totally charged because you had it on a battery tender?
Back to top
View user's profile Send private message  
cummingsjc
Member


Joined: 30 Dec 2015
Posts: 331
Location: College Station, TX
Genuine Buddy 50cc, Genuine Mean Cat, Piaggio MP3-500 (Desert Camo), MP3-400 (Pinky)

PostPosted: Tue Aug 15, 2017 3:09 pm    Post subject: Reply with quote

When you turn on the key, is anything coming on such as the gauge cluster or lights (however weakly)?
Back to top
View user's profile Send private message  
chachamooby
Member


Joined: 19 Oct 2016
Posts: 16
Location: VA
2010 Genuine RH50

PostPosted: Tue Aug 15, 2017 10:01 pm    Post subject: non start Reply with quote

if the lights come on but won't crank than the battery might just be weak.
if lights come on than try this--
--I know this sounds odd but try putting more gas in it--really almost full.
If mine sits, and the gas gauge says half or less, it won't start.
Fill it up and watch it go--kick start it.
If no lights than the battery has a bad connection or the ignition switch is mucked up--could anyone have tried to take it while you were away?
AJ

_________________
2002 Yamaha FZ-1
Baja Doodle bug Smile
Back to top
View user's profile Send private message  
mikethegreat
Member


Joined: 14 Aug 2017
Posts: 3
Location: DENVER
RoughHouse

PostPosted: Wed Aug 16, 2017 3:21 pm    Post subject: Reply with quote

Yeah that seemed to fix the issue somehow! I also did just kind of put the kill switch on and off a few times and sure enough, it's starting now!

Thanks for the responses guys, appreciate the help!
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    Forums » Black Cat, Rattler & Roughhouse Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.