Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Looking for an Air Leak

 
Post new topic   Reply to topic    Forums » Blur Discussion Previous topic :: Next topic  
Author Message
HanShan
Member


Joined: 13 Apr 2017
Posts: 145
Location: Missoula, MT
Nothin' right now...

PostPosted: Mon Aug 28, 2017 2:34 pm    Post subject: Looking for an Air Leak Reply with quote

So I have been trying to find an air leak in my 2013 Blur to see if that could be the source of my funky RPMs, at idle and at speed.

I sprayed carb cleaner around some of the seams while idling but no change in RPMs. I am not sure I have hit it in all the possible places though. I will have a camera later today and will post pictures where I sprayed, but mostly on the top after taking off the seat and cat carrier.

I am doing this because my Buddy Dealer said there might be an air leak.
Back to top
View user's profile Send private message  
HanShan
Member


Joined: 13 Apr 2017
Posts: 145
Location: Missoula, MT
Nothin' right now...

PostPosted: Fri Sep 01, 2017 7:38 pm    Post subject: Reply with quote

Nobody? Anybody?
Back to top
View user's profile Send private message  
scootbwh
Member


Joined: 17 Sep 2017
Posts: 29


PostPosted: Sat Nov 11, 2017 7:25 pm    Post subject: Reply with quote

Same - I think I may have this issue.
Back to top
View user's profile Send private message  
HanShan
Member


Joined: 13 Apr 2017
Posts: 145
Location: Missoula, MT
Nothin' right now...

PostPosted: Mon Nov 13, 2017 3:46 pm    Post subject: Reply with quote

How much does your idle vary? Mine seems better but still between 1400 and 2000.
Back to top
View user's profile Send private message  
scootbwh
Member


Joined: 17 Sep 2017
Posts: 29


PostPosted: Mon Nov 13, 2017 5:27 pm    Post subject: Reply with quote

HanShan wrote:
How much does your idle vary? Mine seems better but still between 1400 and 2000.


I don't have an idle variance issue really (mine stays around 1800-2000) or so when warmed, however sometimes when warming up it revs pretty high before settling down. Similarly, if I twist the throttle, it will hang for a good minute or so at high rpms before it fully makes it way back to idle speed.

Don't ask why I tried this, but I did...
When it was idling really high after revving it, I switched the ignition switch off for half a second and turned it back on...just enough time that the motor didn't turn completely off. It idled like it should after doing that. Why? I don't know. Its repeatable too.

These things have been a PITA.
Back to top
View user's profile Send private message  
chickdr
Member


Joined: 03 Jul 2009
Posts: 275
Location: Atlanta, GA
'11 Blur SS220i , '13 FZ6R

PostPosted: Wed May 16, 2018 2:35 pm    Post subject: Reply with quote

Sounds similar to what I have been experiencing. Mine will at times decide to idle around 2k/2100rpm. This often happens after I have been riding for a while. Lately it happens at startup and I also have a lot of popping/backfire type sounds with a closed throttle and as I slow from speed. When it idles normally, no such sounds with a closed throttle. Normal idle for me is 1500-1700 rpm.
Back to top
View user's profile Send private message  
HanShan
Member


Joined: 13 Apr 2017
Posts: 145
Location: Missoula, MT
Nothin' right now...

PostPosted: Thu Jul 05, 2018 8:45 pm    Post subject: Reply with quote

chickdr wrote:
Sounds similar to what I have been experiencing. Mine will at times decide to idle around 2k/2100rpm. This often happens after I have been riding for a while. Lately it happens at startup and I also have a lot of popping/backfire type sounds with a closed throttle and as I slow from speed. When it idles normally, no such sounds with a closed throttle. Normal idle for me is 1500-1700 rpm.


Wondering, since your voltage regulator died, that it might have been part of the issue? I sold my blur so no idea.
Back to top
View user's profile Send private message  
scootergrind
Member


Joined: 09 Dec 2013
Posts: 40
Location: Redding, CA
2011 SS Blur 220i

PostPosted: Fri Jul 06, 2018 5:09 am    Post subject: Reply with quote

Mine does the occasional "up-idle" thing as well, and like chickdr, it occurs when coming to a stop after running awhile. Only trick I've found to knock the revs back down is to blip the throttle. That usually takes care of it. At least it doesn't hurt the scoot in any way, nor does it happen all that often. Maybe it's just the Blur's way of showing how excited it is to be ridden - chomping at the bit!
Back to top
View user's profile Send private message  
chickdr
Member


Joined: 03 Jul 2009
Posts: 275
Location: Atlanta, GA
'11 Blur SS220i , '13 FZ6R

PostPosted: Wed Jul 11, 2018 10:57 pm    Post subject: Reply with quote

After having the issue posted in another thread with my voltage regulator burning up, I am going to throw out the possibility of this being the cause of the idle fluctuations. I propose it may have been on its way out so was causing issues. I just got mine back today with a new voltage regulator installed and it is running like new. $110 part.
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    Forums » Blur Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.