Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Pulsing Front Brakes and other questions

 
Post new topic   Reply to topic    Forums » Stella Discussion Previous topic :: Next topic  
Author Message
charleetho
Member


Joined: 03 Aug 2018
Posts: 1
Location: Omaha!
Stella 4T

PostPosted: Fri Aug 03, 2018 5:00 pm    Post subject: Pulsing Front Brakes and other questions Reply with quote

Hi, New to the list. New to scooters. Been riding motorcycles for 40 years (read as old as dirt)

Anyway. My new to me 2013 Stella 4T has a pulsing front brake. Most noticeable from 10mph down to a stop.

Suggestions to fix? Maybe normal?

Next Q

Gas gauge always reads empty. Took out the float. Moved it up and down and nothing changed.

Again, suggestions.

Last Q

Anybody upgrade the headlight to a bright LED or add lights> I feel invisible on this thing. People pull out all the time. Something that rarely happens on my big red pig (GL1800 Goldwing)

Thanks in advance.
Back to top
View user's profile Send private message  
Mr.FixIt
Member


Joined: 01 Aug 2018
Posts: 36
Location: York, PA, USA
Stella 2T

PostPosted: Thu Aug 23, 2018 2:19 am    Post subject: Reply with quote

I'm new to scooters too, just trying to figure out the finer points.

Pulsing front brakes sounds like either a warped rotor or a rough spot on the rotor???

Just this evening, I fixed my gas gauge sender by following this thread.
http://www.modernbuddy.com/forum/viewtopic.php?t=27982&highlight=gas+gauge

I considered upgrading to LED lamps too, but I haven't had the bike long enough to act on the thought. A friend of mine makes his own LED lamps primarily for British cars. We certainly want to be seen on our our Stella scoots.
http://velocesolutionsllc.com/Exterior-Lighting_c4.htm

_________________
Eric
(aka Mr. Fix It)
Back to top
View user's profile Send private message  
Stanza
Member


Joined: 29 Jan 2018
Posts: 261
Location: Chicago
Puch Maxi

PostPosted: Thu Aug 23, 2018 1:57 pm    Post subject: Reply with quote

Doublecheck the allen head bolts holding the rotor to the hub, make sure they are snug (locktite if they are loose)
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    Forums » Stella Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.