Looking for input from the MB think tank - Idle Issue

Discussion of the Genuine Buddy, Hooligan, Black Jack and other topics, both scooter related and not

Moderator: Modern Buddy Staff

Post Reply
User avatar
DeeDee
Member
Posts: 878
Joined: Sat Jul 26, 2014 5:07 pm
Location: Denver

Looking for input from the MB think tank - Idle Issue

Post by DeeDee »

I have a 2008 125 with 6,500 miles. Scooter is in decent shape. Runs great once it is running, but won't idle after it has been turned off and sits. Idles fine once it has been warmed up. Carb has been thoroughly cleaned. Auto enrichener has been tested and is reading as it should. I have also swapped it with another one just to be sure. I don't think it is a temperature issue as much as a sitting issue. Petcock has been tested and doesn't flow without suction. Fuel system has been flushed, and fuel filter replaced. I sprayed ether around the carb and intake, no vacuum leaks present. I have replaced the coil, plug wire and cap. I have adjusted the valves. The intake valve was a bit tight. I've replaced the stator and CDI. I have cleaned the float needle seat, replaced the needle valve and set the float to 18mm. I am out of ideas. It is running the same as before I began working on it. WHAT AM I MISSING?
User avatar
charlie55
Member
Posts: 1952
Joined: Tue Apr 08, 2008 6:47 pm
Location: New Jersey

Post by charlie55 »

After it has sat for a while (the situation in which the problem occurs), try partially blocking the intake/air box with a rag. If it starts and idles OK, then your starting mixture is too lean.

It can't be the bystarter since you checked with two of them, so I'd double check the enrichment pathway itself. I know you cleaned the carb, but sometimes crud gets in the worst possible place and decides it likes the neighborhood.

It's a really, really long shot, but I had an '06 Blur that would never start easily. It turned out to be a faulty casting of the carb bowl - there was a small, separate portion that fed the enrichment circuit. The hole between it and the rest of the bowl was completely blocked from the factory.
Image
User avatar
DeeDee
Member
Posts: 878
Joined: Sat Jul 26, 2014 5:07 pm
Location: Denver

Post by DeeDee »

Thank you charlie55, exactly the type of input I was hoping for. I'll give it a shot tomorrow.
Post Reply