Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

rebuilt carb - now scooter doesn't have much acceleration

 
Post new topic   Reply to topic    Forums » General Discussion Previous topic :: Next topic  
Author Message
PistolPete7390
Member


Joined: 03 May 2017
Posts: 23
Location: Manchester NH
Buddy 125

PostPosted: Wed Sep 16, 2020 4:58 pm    Post subject: rebuilt carb - now scooter doesn't have much acceleration Reply with quote

Had a friend rebuild my carb on 2007 buddy 125 and now the scooter doesn't have any acceleration power past 30mph. Looking for help to troubleshoot this issue. Thanks in advance [/b]
Back to top
View user's profile Send private message  
vintagegarage
Member


Joined: 22 Nov 2017
Posts: 86
Location: Florida
2006 Buddy 125, 2003 MyBuBu 125, 2009 Buddy 50, St. Tropez, 2009 Buddy 150, International Italia

PostPosted: Wed Sep 16, 2020 5:21 pm    Post subject: Reply with quote

Carb diaphragm isn't installed properly.. Take the diaphragm cover off, re-seat the diaphragm, put the cover back on, fixed.
Back to top
View user's profile Send private message  
PistolPete7390
Member


Joined: 03 May 2017
Posts: 23
Location: Manchester NH
Buddy 125

PostPosted: Wed Sep 16, 2020 6:22 pm    Post subject: Reply with quote

Thank you very much! I will have him try this tonight.
Back to top
View user's profile Send private message  
babblefish
Member


Joined: 04 Dec 2007
Posts: 3107
Location: San Francisco
2006 Blur 180, 2008 Buddy St. Tropez

PostPosted: Thu Sep 17, 2020 1:43 am    Post subject: Reply with quote

You might have to put a little bit of rubber safe lubricant on the sealing lip before assembly. It'll help it make a good seal.
_________________
Some people can break a crowbar in a sandbox.
Back to top
View user's profile Send private message  
wheelbender6
Member


Joined: 07 Jul 2013
Posts: 729
Location: Houston area
Genuine Buddy 125

PostPosted: Thu Sep 17, 2020 8:51 pm    Post subject: Reply with quote

I agree with all the responses. I had the same problem a little over a year ago. Easy fix.
_________________
"It's not WHAT you ride, but THAT you ride" - unknown
Back to top
View user's profile Send private message  
Display posts from previous:   
Post new topic   Reply to topic    Forums » General Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.