Forums
 FAQHelp  LinksLinks    SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Seat Issues

 
Post new topic   Reply to topic    Forums » General Discussion Previous topic :: Next topic  
Author Message
GenuineSlacker
Member


Joined: 01 Oct 2006
Posts: 98
Location: Houston, TX
Cream Buddy 125 (Emiko, Emi for short)

PostPosted: Sun Oct 15, 2006 1:07 am    Post subject: Seat Issues Reply with quote

Well a day or so after I got my buddy home I started having problems opening my seat cubby (hereby reffered to as my puppy warmer). It locks fine and I can still open it by lifting when I turn the key. My only problem is the lock doesn't seem to want to release without a little lifting pressure. Tried WD40, let me know if anyone knows of any easy fix to this problem.
_________________
"Angels who are forced from heaven have no choice but to become demons." - Vicious
Back to top
View user's profile Send private message [ Hidden ]
avidgirl
Member


Joined: 19 Aug 2006
Posts: 46
Location: Stamford, CT
Buddy 125

PostPosted: Sun Oct 15, 2006 1:34 am    Post subject: Reply with quote

This seems to be a common problem with the Buddy scooters. I know that there was a fix discussed here so try the search feature using "latch" or "seat". I can't remember specifics but it seems like the cable loses tension and needs to be tightened.

Congrats on your new Buddy!

_________________
Leigh

__________________________________

Creme Buddy 125
Back to top
View user's profile Send private message  
brat
Member


Joined: 20 Sep 2006
Posts: 146
Location: San Francisco, CA
'77 Vespa rally 200 '06 Buddy 125

PostPosted: Sun Oct 15, 2006 1:37 am    Post subject: Reply with quote

http://www.modernbuddy.com/forum/viewtopic.php?t=152&highlight=latch

Look here.

Susan
Back to top
View user's profile Send private message   AIM Address Yahoo Messenger MSN Messenger
vitaminC
Member


Joined: 07 Aug 2006
Posts: 768
Location: Redwood City, CA
ex '06 B125

PostPosted: Sun Oct 15, 2006 2:04 am    Post subject: Reply with quote

That was one of the things fixed at my service today. Glad to see it's an easy fix should it become an issue again!
Back to top
View user's profile Send private message   Visit poster's website
GenuineSlacker
Member


Joined: 01 Oct 2006
Posts: 98
Location: Houston, TX
Cream Buddy 125 (Emiko, Emi for short)

PostPosted: Sun Oct 15, 2006 3:45 am    Post subject: Reply with quote

Yeah thanks for the help guys. I fixed it, then as soon as i got the cowl cap back on it wouldnt work, so i did it again, removed my headlights, had to fix it again and its been working fine since, almost 3 hours WOO
_________________
"Angels who are forced from heaven have no choice but to become demons." - Vicious
Back to top
View user's profile Send private message [ Hidden ]
Display posts from previous:   
Post new topic   Reply to topic    Forums » General Discussion Previous topic :: Next topic  Time: GMT

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

  Scootergear designed by riders for riders


Powered by phpBB © 2001, 2005 phpBB Group
All Content Copyright 2007-2011 by Modern Buddy. All Rights Reserved.